Google Chrome browser issues on Eden?

  • Save 15% sitewide — code: THRILL15

Google Chrome browser issues on Eden?

doowop doowop
I wonder if anyone else is having this problem, or if it's been reported before. I tried searching but didn't find much.

Whenever I'm trying to load a page, it's a hit or miss whether it'll actually load. It usually ends up bringing me to an error page, and this is only specific to EdenFantasys and especially when posting on the forum. Many times I'll have to copy what I'm posting cuz it'll take me to an error page (kind of like the no internet connection page, but my connection is fine) so I'll have to backup and try posting it again. Have any of you had the same issues with Chrome? I just switched from Firefox and that didn't give me an issue. Have the admins heard of these issues before? I wonder what's up or why Chrome doesn't like Eden.
  • Black Friday Sale! Save 80% on select items
  • Black Friday Sale! Save 50% on select items
  • Black Friday Sale! Save 40% on select items
  • Black Friday Sale! Save 30% on select items
  • Black Friday Sale! Save 25% on select items
  • 1
  • 2
  • 3
  • 4
  • 5
All promotions
doowop doowop
Also, I apologize if this is in the wrong section. I'm sure it's an issue on Chrome's side, but if anyone has experienced this and knows of a quick fix please let me know.
El-Jaro El-Jaro
Nope, you're right about the section.

Basically, it's on Chrome. The best thing to do is dump the cache and clear the cookies. That's the first thing to try if there are any tech issues on site. If that doesn't work, go ahead and shoot me or Stormy an email or on-site message.

Have a great day!
doowop doowop
I tried that the other day with no success. But I'll try it again and let you know. Thanks!
Total posts: 4
Unique posters: 2